Java If-Else
In this challenge, we test your knowledge of using if-else conditional statements to automate decision-making processes. An if-else statement has the following logical flow:
Source: Wikipedia
Task
Given an integer,
, perform the following conditional actions:
is odd, print
If
is even and in the inclusive range of to
, print
If
is even and in the inclusive range of to
, print
If
is even and greater than
Explanation
is odd and odd numbers are weird, so we print
Sample Case 1:
and is even, so it isn't weird. Thus, we print
Source: Wikipedia
Task
Given an integer,
, perform the following conditional actions:
- If
Weird
Not Weird
Weird
- , print
Not Weird
is weird.
Input Format
A single line containing a positive integer,
.
Output Format
Output Format
Print
Sample Input 0
Sample Input 1
Weird
if the number is weird; otherwise, print Not Weird
.Sample Input 0
3
Sample Output 0Weird
Sample Input 1
24
Sample Output 1Not Weird
Explanation
Sample Case 0:
is odd and odd numbers are weird, so we print
Weird
.Sample Case 1:
and is even, so it isn't weird. Thus, we print
Not Weird
.
import java.io.*;
import java.math.*;
import java.security.*;
import java.text.*;
import java.util.*;
import java.util.concurrent.*;
import java.util.regex.*;
public class Solution {
private static final Scanner scanner = new Scanner(System.in);
public static void main(String[] args) {
int N = scanner.nextInt();
scanner.skip("(\r\n|[\n\r\u2028\u2029\u0085])?");
if(N%2==1)
System.out.println("Weird\n");
else{
if(N>2&&N<5)
System.out.println("Not Weird\n");
else if(N>6&&N<=20)
System.out.println("Weird\n");
else
System.out.println("Not Weird\n");
}
scanner.close();
}
}
Comments
Post a Comment